Console Login Problem for Private Instances
Incident Report for Mondoo
Postmortem

Starting at 18:18UTC (Dec 6th) an update to the OIDC login page used by private instances was deployed that caused the page to fail to load. The issue was quickly identified and triaged. At 19:17UTC the change was rolled back and service resumed working properly. At 19:46UTC a complete fix for the problem was deployed and the incident fully resolved.

We are taking steps to improve our pre-deployment testing to avoid such an occurrence in the future.

During this incident only console logins (the Web UI) were impacted, the server continued to fully function and process scans as usual.

This problem did not impact the public services (https://console.mondoo.com) which do not use the OIDC login page.

Posted Dec 06, 2023 - 19:54 UTC

Resolved
Customers with private instances are experiencing problems with the OIDC Login Page, the problem has been identified and resolved.
Posted Dec 06, 2023 - 18:30 UTC