AWS Integrations Require Manual Update
Incident Report for Mondoo
Resolved
This incident has been resolved.
Posted Jun 03, 2024 - 21:26 UTC
Monitoring
A recent update to the Lambda functions which support our AWS Integrations has caused integrations to stop syncing and manual intervention is required to correct the function. We apologize for the inconvenience. Please follow these instructions to correct the problem:

In the Mondoo Console, on the left-hand nav bar, expand "Integrations" and select "AWS". For each integration marked as "MISSING" you'll need to perform the following procedure:

1. Login to the impacted AWS account
2. Navigate to "Lambda"
3. Select the "MondooLambda" function
4. Under "Code source", select "Upload from" and then "Amazon S3 Location"
5. Specify the Amazon S3 Link URL "https://s3.amazonaws.com/mondoo.{REGION}/mondoo-lambda-arm.zip", where {REGION} is the region of the function, ie: 'us-east-1', the dot between mondoo and the region is required.

Within 10 minutes you should see your AWS Integration become "Active". Repeat for each integration until all are active.

If you require any additional assistance please contact support@mondoo.com
Posted May 14, 2024 - 21:26 UTC